guest additions worked perfectly after that, so now have crunchbang in fullscreen :-) SO I ran "sudo apt install steamcmd" and it worked. sudo add-apt-repository multiverse sudo dpkg --add-architecture i386 sudo apt-get update sudo apt-get install lib32gcc1 steamcmd. edit: maybe I forgot to paste the last command but when I ran "steamcmd" it said it wasn't installed, so maybe I forgot to install it. Top. But bear in mind that if you use etch you will only get security updates, you won't get a newer version of a package. I'm having trouble installing any package on my Raspberry Pi v1 B. Whenever I run apt-get install [any package here], it always failed with E: [package name] has no installation candidate. > >>This typically means that the package was mentioned in a dependency and > >>never uploaded, has been obsoleted or is not available with the contents > >>of sources.list > >>E: Package proftpd has no installation candidate > >> > >>I can't find it with apt-cache search either. I don't understand why this is so, as it was working some time ago.

Same for Synaptic.. apt-cache search x seems to show many results for basic searches so why not for these 2 popular package managers? Code: Select all $ sudo … This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'firefox' has no installation candidate mahdi@debian:~$ mahdi68 Posts: 3 Joined: 2011-05-16 11:27. Any help much appreciated. Done Package aptitude is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source Already did apt-get update.

by dilberts_left_nut » 2011-05-16 12:12 . Re: linux-headers has no installation candidate [RESOLVED] thanks @vicshrike and @unia, installing the 2.6.32-5-amd64 headers was the answer. I haven't changed my sources list after installing, could something in the sources cause this? Debian User Forums.

apt-get upgrade and aptitude upgrade download and install the most recent update of packages that are already installed in your system. Done > >>Package proftpd has no available version, but exists in the database. My APT sources.list Re: how to install firefox on debian 6 ?

Skip to content . Package dialog is not available, but is referred to by another package. E: Package 'aptitude' has no installation candidate."

Package metasploit-framework is not available, but is referred to by another package.